BrailleBlaster System Requirements

Software Requirements

When using one of the BrailleBlaster installer packages you will need a computer running one of the below operating systems.

  • Windows 10 or Newer
  • Mac OS X or Newer
  • Ubuntu Linux 20.04 or later

Only if using the universal zip archive distribution of BrailleBlaster you will also need Java15 or higher installed on your computer.

Hardware Requirements

  • 64-bit computer with 64-bit operating system installed.
  • 4 GB RAM, 6 GB is recommended.

BrailleBlaster works best with a high resolution monitor, although this is not required.

Legacy BrailleBlaster Version 1 Requirements

Software Requirements

<

A computer with one of the following operating systems installed.

  • Windows 7 or higher
  • Mac OS X or higher
  • Linux with Java8 installed.

Hardware Requirements

  • A 32-bit or 64-bit computer.
  • 4 GB RAM, 6 GB is recommended.

BrailleBlaster works best with a high resolution monitor, although this is not required.